Jump to content

Download full cache data of more than 50 entries stalls.


Recommended Posts


I can't successfully download more than 50 entries of full cache data from an online list or a PQ any more. This started a while back without changing anything on my side (still Cachly 7.1.1), so I guess it's due to some changes on the GC API server side.

This is what happens:

I see the list of multiple pending network requests (50 caches in each) but only the last one ever completes while all the other ones remain in 'downloading' state forever.

How to make it happen:

  1. Tap on 'Lists' in the bottom menu bar
  2. Tap on 'Online' in the top tab chooser
  3. Locate a list with more than 50 entries (e.g. 133)
  4. Tap on the three dots next to it and select "Download Full List"
  5. Choose "Full Cache Data"


The last of the network requests (e.g. 101 - 133) eventually finishes...


...but the other ones (e.g. 1 - 50 and 51 - 100) stay in "Downloading..." forever.



Can you please have a look if this is a general issue and how it can be fixed?

Thanks a lot


Link to comment
Share on other sites

Alright, thanks a lot for the first feedback. The info that it's NOT that simple made me experiment a bit more.

I've been able to narrow it down to a list containing just 48 entries which I'm sharing here. For me it never works when trying to load the whole list with full cache data. I've tried two different iOS devices, one is an iPhone 8 with iOS 16.4.1 and a fresh install of Cachly 7.1.1, the other one is an iPhone SE with iOS 15.7.4 and Cachly 7.1.1 never removed since the day I started using it. I've tried mobile networks German T-Mobile, O2-Germany and my German Telecom DSL. Nothing makes a difference, it fails (i.e. stalls forever) every time. I don't have any weird security settings active.

Can you please make a copy of my shared list into your own GC account, try to load that list into Cachly like the way I do and see if you can reproduce the effect at all?

I would be very grateful if we could shed some light on this. :)



Link to comment
Share on other sites

Very interesting:

If I split the list in two halves then both halves work.

Back to my non-working list: I tried removing just one randomly picked entry and it made it work.

So I thought this randomly picked entry might be suspicios, so I added it to another, previously working list -> It doesn't break it. Still works.

Once again back to my non-working list: I tried removing another randomly picked entry and it still doesn't work.

By the way, the results are always repeatable. A particular list that fails always fails no matter when or how often I try t load it. Another particular list that works always works. So it's not just a random glitch which might make me think certain things work while others don't.

Very strange.


Link to comment
Share on other sites

Hi Nic,

I've tried all of this on wifi and two different cell networks. The results are always the same. I've even tried it on two different iOS devices.

To rule out as many side effects as possible I've now done the following...

Within a single Cachly session and without interrupting the network connection:

  1. Try to load the failing list from my main account -> fail
  2. Log out and log in with our team account
  3. Try to load an exact copy of this list from the team account -> success after ~36 seconds
  4. Log out and log back in with my main account
  5. Same as step #1 -> still fails

So the differences are:

  • It's a different account which might end up on a different GC server for load/data balancing ? (don't know)
  • It's certainly different personal data (notes, corrected coordinates, found status) between the two accounts.

Very strange... new debug data is on its way to you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...