Jump to content
Pfalstad

two name-based filters don't work right together

Recommended Posts

If I try to filter out caches that contain the string "X" or "Y", using two name-based inverted filters, it doesn't work.  It matches all caches, even if they have "X" or "Y" in the name.  If you turn off one of the two filters, then it works as expected.

Also, if I try to match only caches that contain the string "X" and the string "Y", then it actually gives me all caches that contain either "X" or "Y", even if I have logic set to "AND".

See attached screenshots for the first case (I'm trying to filter out caches with "Dog" or "Chopsticks" but it still gives me caches that contain those words)

 

IMG_0015.jpg

IMG_0016.jpg

Share this post


Link to post
Share on other sites

This issue has been solved in 5.0. Instead of adding multiple filters to allow multiple terms, there is a new "Contains Multiple" option for string filters. This will allow you to use a comma separated list of terms. This feature has been tested with the issue you mentioned and it solves the problem with inverted terms.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×